Error parsing XML from 3D buttons

Error parsing XML from 3D buttons

  • 1 marzo 2013 alle 1:27 pm #20982
    jziguiri
    Partecipante

    Hi,

    I’m trying to generate some elements from the screens by using C# and when I try to parse the XML from a screen file that contains a 3DButton I get errors. The offending line is:

    <Mechanic CheckVariable='' MechanicStyle='2' CentralZero='0' PushStyle='1' 3DRoundLevel='1' clickable='1' NumOptBtn='5' RadioCheckSize='0' Impulsive='1'>0</Mechanic>

    The ‘3DRoundLevel’ attribute name doesn’t validate as XML because starts with a number… how can I parse this elements?

  • 11 marzo 2013 alle 6:00 pm #20983
    Ian_C
    Membro

    Hi,

    have you got an old version of Movicon? This because in my 3D buttons, the Tag 3DRoundLevel doesn’t exists…
    If I try to create it, I get an error also opening the file .movscr from an XML Editor, so I think that is a little problem of the Movicon version you are using.

    Regards!

  • 12 marzo 2013 alle 11:32 am #20984
    jziguiri
    Partecipante

    Hi Ian,

    I’m able to replicate this issue using movicon’s latest version (11.3.1104). Just drag a ‘3D Button 3’ control from the ‘Basic controls’ tabs of the toolbox and you should get the  3DRoundLevel=’1′ attribute.

    Thanks!

  • 12 marzo 2013 alle 6:11 pm #20985
    Ian_C
    Membro

    Hi,

    ok, now I saw.. I tried with the 3D button Style 1 and with that object you can’t see the error.
    In my opinion you can report it to the support of Progea.

    Regards

Devi essere loggato per rispondere a questa discussione.