OPC UA Browser

OPC UA Browser

  • 11 giugno 2019 alle 11:20 am #32829
    [email protected]
    Partecipante

    Hello,

    I am using KEPServerEX software for OPC Server and I want to connect it via Movicon.Next Client interface.

    When I add server endpoint URL in OPC UA Browser, it is added to the list. After double clicking it, it requires Windows user ID and password, and I am entering it.

    There comes confirmation window that says “certificate not validated”, and i accept it anyway. But I get OPC UA Session Failed: BadUserAccessDenied message.

    I checked port that comes in the end of my server endpoint url. It is open.

    I also checked “OPCUAClient.Config” file and changed AutoAcceptUntrustedCertificates from false to true. But nothing changed.

    Beforehand I used to connect Matrikon OPC Server for simulation purpose. And I couldn’t do it like this situation. What is that problem with Movicon.Next? I have my college who can directly connect with those servers, but I cannot. How can I handle that problem? If it is due to some settings of my PC, what should I change?

  • 13 giugno 2019 alle 5:24 pm #32856
    73David
    Partecipante

    Hello,
    **
    Certificate could not validate: BadCertificateUntrusted
    Subject: PC1
    **
    There must be an invalid certificate on the PC…

    Please check in the path :

    “C:\ProgramData\OPC Foundation\CertificateStores\RejectedCertificates\certs”

    or in the path:

    “C:\ProgramData\OPC Foundation\UA\Discovery\pki\rejected”

    If there aren’t certificates classified as invalid or rejected.

    Try to clean this folders.

    Kind Regards
    David

  • 24 gennaio 2020 alle 1:24 pm #35458
    [email protected]
    Partecipante

    hi,
    facing same issue AS ABOVE

    opc server is not connecting checked the port at the KEPServer seems port is clear.

    “C:\ProgramData\OPC Foundation\UA\Discovery\pki\rejected” tried no changes

    I get “KEPServerEX/[email protected] – OPC UA Session Failed : No such host is known”

    HELP ME TO SOLVE IT…

    regards
    Dhakshin

  • 24 gennaio 2020 alle 5:35 pm #35461
    Kristof70
    Partecipante

    Hi

    Try to set = to true in the OPCUAClient.Config.xml file the parameter

    <AutoAcceptUntrustedCertificates>false</AutoAcceptUntrustedCertificates>

    Default is false.

    from the last message posted related to the host not visible ,if you cannot solve, try to reinstall the OPC UA Local Discovery

    Control Panel\All Control Panel Items\Programs and Features, un-install the existing.
    Then you can reinstall from the Movicon.NExT setup folder OPC UA Local Discovery Server 1.02.

    BR
    Kris

Devi essere loggato per rispondere a questa discussione.